Operating Environments

enebular

The web browsers supported by enebular are as follows.

Web Browser Version OS
Chrome 63.0 or later Windows/Mac
Firefox 57.0 or later Windows/Mac
Safari Coming soon Mac
Microsoft Edge Coming soon Windows
  • The above browsers are recommended for use with enebular. Please contact support if an issue occurs such as something not displaying correctly or a function not working correctly.
  • It has been found that enebular does not work properly when using some Chrome extensions. We recommend disabling unnecessary Chrome extensions when using enebular.

enebular editor

Operating System

The following operating systems are supported.

  • Windows 10
  • macOS v10.13

The middleware versions for each are as follows.

OS npm
Windows 10 6.0 or later
macOS v10.13 6.0 or later

enebular-agent

enebular-agent is IoT agent software for enebular and designed for Linux OS gateways. The environments are as follows.

For detailed specifications, please contact support ([email protected]).

Recommended Hardware

The enebular-agent runs on Linux. The following are examples of recommended hardware for inexpensive gateway environments which run Linux.

Product Version
Raspberry PI3 Model B Version 3 Model B
OpenBlocks Coming soon

Requirements

  • Network Interface (ethernet or Wireless network)
    • For Wireless network, IEEE802.11a/b/g etc is assumed, but anything where an IP network connection from Linux can be used.
  • SD-Card
  • RAM
  • Flash Memory

Operating System

The enebular-agent runs on Debian GNU/Linux. For the recommended Raspberry PI hardware, use the Debian based Raspbian OS.

enebular-agent 2.10.0 or later

Raspberry PI3

The following operating systems are supported for use with the Raspberry PI3.

The middleware versions for each are as follows.

Node.js npm Node-RED
streach base (9.0) 12.14.0 6.13.4 0.18.6
Linux (VirtualBox)

For Linux, the following operating systems are supported.

The middleware versions for each are as follows.

Node.js npm Node-RED
Linux 9 Stretch 12.14.0 6.13.4 0.18.6
Linux 8 Jessie 12.14.0 6.13.4 0.18.6

under enebular-agent 2.10.0

Raspberry PI3

The following operating systems are supported for use with the Raspberry PI3.

The middleware versions for each are as follows.

Node.js npm Node-RED
streach base (9.0) 9.2.1 5.5.1 0.18.6
jessie base (8.0) 9.2.1 5.5.1 0.18.6
Linux (VirtualBox)

For Linux, the following operating systems are supported.

The middleware versions for each are as follows.

Node.js npm Node-RED
Linux 9 Stretch 9.2.1 5.5.1 0.18.6
Linux 8 Jessie 9.2.1 5.5.1 0.18.6

Support enebular function

- v2.3 v2.4 v2.5 v2.6 v2.7 v2.8+
Flow Deploy*1
File Deploy
AI-Model Deploy
Flow Start/Stop*2

*1 Flow Deploy scheduling is possible with v2.5 and above

*2 Flow Start/Stop scheduling is possible with v2.8 and above

enebular-edge-agent

enebular-edge-agent is IoT agent software for enebular and designed for microcontrollers utilizing ARM Ltd.'s Mbed OS.

For detailed specifications, please contact support ([email protected]).

Operating Environment

Operating System

Hardware

The following hardware is supported in enebular-edge-agent 1.1.0 and above (except for 1.2.2).

The following hardware is supported in enebular-edg-agent 0.9.0 to 1.0.1 and 1.2.2 and above.

  • ARM® Cortex™-M4 or higher, RAM: 256 KB or higher, Flash: 1 MB or higher microcontroller and wireless network enabled microcontroller board.

※ Please contact our support ([email protected]) for compatible microcontroller boards.

Communication

  • IEEE 802.11 b/g/n (only 2.4GHz is supported for IEEE 802.11n)
  • WPA/WPA2

Support enebular function

- v1.3 v1.4+
Flow Deploy*1
Flow Start/Stop*2

*1 Flow Deploy scheduling is not supported

*2 Flow Start/Stop scheduling is not supported

enebular Reference Board Configuration Tool

OS CPU Memory Other
Windows 10 Core i5 2.90GHz and up 8.0GB and up .NET Framework v4.6.1

Enebular Infomotion Tool

The web browsers supported by enebular-infomotion-tool are as follows.

Web Browser Version OS
Chrome 63.0 or later Windows/Mac
Firefox 57.0 or later Windows/Mac
Safari Coming soon Mac
Microsoft Edge Coming soon Windows

Npm Version

nodejs >= 6 and npm 5.2+

Possible Issues

If a permission error occur the following solutions may solve it.

  1. Give permission to current user to global node_modules in /usr/local/lib/ node_modules. Once persmission given retry global install. MacOSX: https://support.apple.com/kb/PH25287?locale=en_US Windows: https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc754344(v=ws.11)

  2. Install nvm to handle node and npm installations. (recommended) MacOSX: https://github.com/creationix/nvm Windows: https://github.com/coreybutler/nvm-windows

  3. Change npm's Default Directory https://docs.npmjs.com/getting-started/fixing-npm-permissions see Option Two.

results matching ""

    No results matching ""